
# ALM-50216 FE节点使用的内存比率超过阈值
#### 告警解释
系统每30秒周期性检查FE节点使用的内存比率，当检查到该值超出阈值（默认值为95%）时产生该告警。
当FE节点使用的内存比率低于阈值时，告警清除。
#### 告警属性
| 告警ID  | 告警级别 | 是否可自动清除 |
|:---|:---|:---|
| 50216 | 紧急   | 是       |
   
#### 告警参数
| 参数名称              | 参数含义                  |
|:---|:---|
| 来源                | 产生告警的集群或系统名称。         |
| 服务名               | 产生告警的服务名称。            |
| 角色名               | 产生告警的角色名称。            |
| 主机名               | 产生告警的主机名。             |
| Trigger Condition | 系统当前指标取值满足自定义的告警设置条件。 |
   
#### 对系统的影响
影响任务执行和客户端连接FE。
#### 可能原因
FE堆内存过小。
#### 处理步骤
**检查FE堆内存使用率。**
1. 登录FusionInsight Manager，选择"运维 \> 告警 \> 阈值设置 \> *待操作集群的名称* \> Doris \> CPU和内存 \> FE节点使用的内存比率 (FE)"。
   
   1. 单击"平滑次数"后的编辑按钮，根据实际使用情况，修改平滑次数配置项，单击"确定"。
   
   2. 单击"操作"列的"修改"，根据实际使用情况，更改告警阈值，单击"确定"。
   
   
   
   
2. 使用**omm** 用户登录告警的FE节点后台，执行**"top"** 查看进程使用内存情况，找到占用较高的内存的进程，检查是否是本服务的进程，是否合理。
   
   - 是，执行[步骤 3]
   
   - 否，对此进程进行隔离、关闭或调整内存大小，并观察机器内存是否被释放出。
   
   
   
   
3. 重启受影响的服务或实例，观察界面告警是否清除。
   
   - 是，处理完毕。
   
   - 否，执行[步骤 4]。
   
   
   ![](https://support.huaweicloud.com/usermanual-mrs/public_sys-resources/notice_3.0-zh-cn.png)
   - 在Doris服务重启期间服务不可用，不能对外提供服务，且其他连接Doris运行的任务也会失败。
   
   - 在实例重启期间，运行在对应实例节点上的任务会失败，未进行重启的实例节点上的任务不受影响。
    
   
   
**收集故障信息。**
4. 在FusionInsight Manager界面，选择"运维 \> 日志 \> 下载"。
5. 在"服务"框中勾选待操作集群的"Doris"。
6. 单击右上角的编辑按钮，设置日志收集的"开始时间"和"结束时间"分别为告警产生时间的前后10分钟，单击"下载"。
7. 请联系运维人员，并发送已收集的故障日志信息。
 
#### 告警清除
此告警修复后，系统会自动清除此告警，无需手工清除。
#### 参考信息
不涉及。
