更新时间:2021-10-15 GMT+08:00
分享

环境要求

系统及软件版本

Kube-OVN是符合CNI规范的网络组件,需要依赖于Kubernetes环境运行,表1列出了支持的系统及软件版本。

表1 组件环境要求

类目

名称

版本

操作系统

CentOS

7.5及以上

Ubuntu

16.04及以上

openEuler

20.03-LTS-SP1及以上

内核

Kernel

3.10.0-898及以上

Docker

Docker Community

1.12.6及以上

Docker CE

18.09.0及以上

Kubernetes

Kubernetes

1.11及以上

环境网络插件

Kube-OVN打包了所需的CNI插件,无需单独安装CNI插件。

为了避免其他网络插件遗留规则和路由对网络产生影响,建议在一个没有安装过其他网络插件的Kubernetes集群上安装Kube-OVN。

如果之前集群安装过其他网络插件,需要预先删除其他网络插件及对应的网卡、iptables规则、路由规则等网络配置。注意检查并确保“/etc/cni/net.d/”路径下无其他网络插件配置文件。

分享:

    相关文档

    相关产品

close