# 实例重部署预处理
#### 操作场景
对于包含本地盘的云服务器，当进行"本地盘换盘"和"实例重部署"事件的"授权重部署"操作时，需要先对本地盘进行实例重部署预处理，避免云服务器异常风险。
实例重部署预处理操作可以通过修改/etc/fstab文件来设置本地盘应用读写隔离，用于提高数据的安全性和系统的稳定性，确保当指定的本地盘出现问题（例如未正确挂载）时，系统不会因为该错误而无法启动。
本文介绍如何对Linux操作系统的磁盘增强型（D系列）和超高I/O型（I系列）的ECS实例进行实例重部署的预处理操作。
![](https://support.huaweicloud.com/usermanual-ecs/public_sys-resources/caution_3.0-zh-cn.png)
对于包含本地盘的实例，实例重部署操作会丢失所有本地盘上的数据，如果无需保留本地盘上的数据，可通过本操作实例重部署预处理。
如果需要保留本地盘上的数据，请勿授权，结束操作并联系技术支持进行处理。
#### 操作步骤
实例重部署预处理，即在实例的/etc/fstab配置文件中为所有数据盘增加nofail参数。
1. [远程登录](https://support.huaweicloud.com/usermanual-ecs/ecs_03_0136.html)待预处理的弹性云服务器。
2. 执行以下命令，打开并编辑/etc/fstab配置文件。 **vim /etc/fstab**
   

3. 单击"i"进入编辑模式，在/etc/fstab配置文件中为所有数据盘加入nofail参数。
   示例如下：
   ```
   UUID-8232fee7-f20a-416c-a2e0-cbc8c85a01a2   /mnt/nvme0n1      ext4   defaults,nofail0 2
   ```
   - UUID-8232fee7-f20a-416c-a2e0-cbc8c85a01a2：数据盘的UUID。
   
   - /mnt/nvme0n1：数据盘挂载点，可通过**mount \| grep "*盘符信息*"**命令进行查询。
   
   - ext4：数据盘的文件系统类型，可通过**blkid** ***盘符信息***命令进行查询。
   
   - nofail：用于设置当文件系统中包含本地盘但实际缺失时，不中断云服务器的启动流程，避免云服务器异常风险。
     
     
4. 单击**:wq**退出编辑模式。
5. 执行以下命令，使配置生效。 **systemctl daemon-reload**
   
6. 执行如下命令，检查/etc/fstab配置文件，若数据盘包含nofail参数，则表示预处理操作完成。 **cat /etc/fstab**
   示例如下：
   ```
   UUID-8232fee7-f20a-416c-a2e0-cbc8c85a01a2   /mnt/nvme0n1      ext4   defaults,nofail0 2
   ```
   
 
