
# 使用限制
- 不支持触发器。
- 不支持临时表。
- 不支持DO语句。
- 不支持外键关联。
- 不支持RESET语句。
- 不支持FLUSH语句。
- 不支持BINLOG语句。
- 不支持HANDLER语句。
- 不支持show warnings。
- 不支持 ':=' 赋值运算符。
- 暂不支持\<=\>运算符。
- 暂不支持'IS UNKNOWN'表达式。
- 不支持INSTALL/UNINSTALL PLUGIN语句。
- 不支持分布式级别的存储过程及自定义函数。
- 库名不可修改，拆分字段的名称和类型都不可以变更。
- 不支持SHOW PROFILES、SHOW ERRORS等多数运维SHOW语句。
- 不支持表维护语句，包括CHECK/CHECKSUM/OPTIMIZE/REPAIR TABLE。
- 不支持session变量赋值与查询。 例如：
  ```
  set @rowid=0;select @rowid:=@rowid+1,id from user;
  ```
  
- 不支持SQL语句中包含单行注释 ' --' 或者多行（块）注释 ' /\*...\*/'。
- 不完整支持系统变量查询，系统变量查询语句返回值为RDS实例相关变量值，而非DDM引擎内相关变量值。例如select @@autocommit返回的值，并不代表DDM当前事务状态。
- 不支持自定义事务隔离级别，目前DDM只支持READ COMMITTED隔离级别。考虑到兼容性因素，对于设置数据库隔离级别的语句（如SET GLOBAL TRANSACTION ISOLATION LEVEL REPEATABLE READ），DDM不会报错，但会忽略对事务隔离级别的修改。
- 不支持设置事务为只读（START TRANSACTION READ ONLY），考虑到兼容性因素，DDM会将只读事务的开启自动转换为开启读写事务。
- LIMIT/OFFSET支持参数范围为0-2,147,483,647。
- 不支持GROUP BY语句后添加asc/desc函数来实现排序语义。DDM自动忽略GROUP BY后的asc/desc关键字。MySQL 8.0.13以下版本支持GROUP BY后添加asc/desc函数来实现排序语义，8.0.13及以上版本已废弃该用法，使用时会报语法错误。推荐使用ORDER BY语句来保证排序语义。
- REPEAT函数结果长度最大限制为1000000（适用于3.0.9版本及以上）。
#### 权限级别支持情况：
- 全局层级（暂不支持）
- 数据库层级（支持）
- 表层级（支持）
- 列层级（暂不支持）
- 子程序层级（暂不支持）
 
