
# 批量登录主机进行运维
通过Web浏览器支持批量登录主机，提供"文件传输"、"文件管理"和"预置命令"等功能。用户在主机上执行的所有操作，被堡垒机记录并生成审计数据。
#### 约束限制
- FTP、SFTP、SCP、DB2、MySQL、Oracle、SQL Server协议类型资源，不支持批量登录。
- 手动登录账户和双人授权账户，不支持批量登录。
- 批量登录的多运维会话窗口，不支持"协同分享"功能。
  ![](https://support.huaweicloud.com/usermanual-cbh/public_sys-resources/note_3.0-zh-cn.png)
  如果批量登录的资源中存在账号和密码不正确的资源，在会话窗口中将无法正常显示，同时也不会报错，需单独登录该资源查看报错信息。
  
 
#### 前提条件
- 已获取"主机运维"模块管理权限。
- 已获取资源访问控制权限，即已被关联访问控制策略或访问授权工单已审批通过。
 
#### 操作步骤
1. [登录堡垒机系统](https://support.huaweicloud.com/usermanual-cbh/cbh_02_0003.html)。
2. 选择"运维 \> 主机运维"，进入主机运维列表页面。
3. 勾选多个目标运维资源，单击"批量登录"，跳转到运维会话窗口。 
   图1批量登录会话窗口   
   ![](https://support.huaweicloud.com/usermanual-cbh/zh-cn_image_0000002172777569.png "点击放大")
   
   
4. 切换资源会话窗口。 
   单击批量登录列表中资源名称，可将切换到目标会话窗口。
   
   
5. 会话窗口操作说明，请分别参见如下说明。 
   - [RDP/VNC协议类型主机会话窗口](https://support.huaweicloud.com/usermanual-cbh/cbh_02_002702.html#cbh_02_002702__zh-cn_topic_0297540792_section18668184463910)
   
   - [SSH/TELNET协议类型主机会话窗口](https://support.huaweicloud.com/usermanual-cbh/cbh_02_002702.html#cbh_02_002702__zh-cn_topic_0297540792_section315183723914)
   
   
   
   
6. 通过文件传输，可对云主机或主机网盘中文件进行上传或下载，详细说明请参见[文件传输](https://support.huaweicloud.com/usermanual-cbh/cbh_02_002707.html)。
7. 通过文件管理，可对云主机或主机网盘中文件或文件夹进行管理，详细说明请参见[通过Web浏览器登录](https://support.huaweicloud.com/usermanual-cbh/cbh_02_002702.html)。
 
