
# 执行SQL语句报错：ERROR 1290 (HY000): The MySQL server is running with the --sql-replica-on option so it cannot execute this statement的原因及解决方案
#### 场景描述
执行SQL语句时，得到如下报错：
```
mysql> create database test;
ERROR 1290 (HY000): The MySQL server is running with the --sql-replica-on option so it cannot execute this statement
```
#### 原因分析
该报错的原因为将增、删、改请求发送到了只读节点。 只读节点会将参数sql_replica_on参数设置为on以禁止增删改请求。
#### 解决方案
请检查写业务的客户端连接IP是否正确，建议连接实例的浮动IP或Proxy的读写IP。
