
# 执行alter table xxx discard/import tablespace报错
#### 场景描述
在TaurusDB中执行alter table xxx discard/import tablespace会报错：ERROR 3658 (HY000)： Feature IMPORT/DISCARD TABLESPACE is unsupported ().
#### 原因分析
alter table xxx discard/import tablespace是社区MySQL一种基于本地.ibd的表空间文件物理的做数据表内容替换（多用于数据迁移、备份恢复等）的方法。
TaurusDB是存储计算分离架构，实际数据存储于共享存储上，本地没有.ibd文件，所以不支持相应的物理操作。
#### 解决方案
使用其他如导入导出、DRS同步、备份恢复等方式做数据表内容的替换。
