
# 使用root账号连接数据库失败
#### 场景描述
使用root账号连接数据库失败。
#### 原因分析
1. 查看内核日志error.log，确认是否有拒绝连接的日志。 ![](https://support.huaweicloud.com/trouble-taurusdb/figure/zh-cn_image_0000002125051733.png)
   
2. 查看root权限，发现有两个root账号，其中一个root限制host必须是IP必须是192开头。 ![](https://support.huaweicloud.com/trouble-taurusdb/figure/zh-cn_image_0000001928570289.png)
   
 
#### 解决方案
请在管理控制台右上角，[提交工单](https://console.huaweicloud.com/ticket/?locale=zh-cn#/ticketindex/createIndex)，联系华为云客服协助删除多余的root账号。
