
# root用户执行PURGE BINARY LOGS报错权限不足
#### 场景描述
root用户在执行PURGE BINARY LOGS命令时，报错信息如下：
ERROR 1227 (42000): Access denied; you need (at least one of) the SUPER or BINLOG_ADMIN privilege(s) for this operation
#### 原因分析
在创建实例时，默认不会授予root用户BINLOG_ADMIN权限，需要手动赋予BINLOG_ADMIN权限。
#### 解决方案
使用root账户给自身授予BINLOG_ADMIN权限。
```
GRANT BINLOG_ADMIN ON *.* TO `root`@`%` WITH GRANT OPTION; FLUSH PRIVILEGES;
```
