
# API到MySQL时源端报"401 unauthorized"错误
#### 原因分析
可能是以下两种原因产生该问题：
- 创建API的时候"安全认证"选择的是"无认证"，创建数据源的时候"认证方式"选了"AppKey Auth"。
- 创建API的时候"安全认证"选择的是"App认证"，创建数据源的时候"认证方式"选了"AppKey Auth"，"App认证方式"选择了"Secret"。
 
#### 解决方案
解决方案如下：
- 创建数据源的时候"认证方式"选择"None"。
- 将"App认证方式"修改为"Default"。
 
