
# Mysql到Mysql时源端报"Illegal mix of collations for operation 'UNION'"错误
#### 原因分析
从源端数据源视图中查看，视图定义语句使用了union，但是union两边字段编码不一致，须统一编码。
#### 解决方案
建议使用CONVERT转换为统一编码，如：CONVERT (ID USING utf8 ) AS ID。
