
# RDS for PostgreSQL创建数据库用户报错：password is easily cracked
#### 场景描述
RDS for PostgreSQL执行创建数据库用户时报错：password is easily cracked
图1报错信息   
![](https://support.huaweicloud.com/trouble-rds-pg/zh-cn_image_0000002248781033.png "点击放大")
#### 原因分析
这是因为使用了弱密码被拦截导致的。在RDS for PostgreSQL 11.22、12.22、13.18、14.15、15.10、16.6及以上的版本中，默认开启弱密码检测。使用弱密码创建用户时，就会发生如上报错。
#### 解决方案
- 建议使用更复杂的密码进行设置，防止密码被暴力破解。
- 如果需要关闭弱密码拦截，可以将参数"passwordcheck.rds_enable_cracklib"的值设置为"off"，从而屏蔽弱密码校验，只做最基本的规则检测。具体操作，请参见[修改RDS for PostgreSQL实例参数](https://support.huaweicloud.com/usermanual-rds-pg/rds_pg_configuration.html)。
  基本规则检测：
  - 密码长度必须大于等于8
  
  - 必须包含字母和非字母
  
  - 密码不能包含用户名
   
 
