
# RDS for PostgreSQL普通账号创建表报错：permission denied for schema public
#### 场景描述
RDS for PostgreSQL创建表报错：permission denied for schema public
具体过程如下：
1. 创建了一个RDS for PostgreSQL 17实例。
2. 以root账号连接数据库postgres。
3. 连接成功后，新建数据库test_001和账号test。
4. 将test_001的owner改为test。
5. 使用test连接test_001数据库，执行以下创建表命令报错：permission denied for schema public
   ```
   create table test001(id varchar(2));
   ```
   
 
#### 原因分析
权限配置问题，需要为普通账号授权。
#### 解决方案
1. 以root账号连接test_001库，执行以下命令为test账号配置权限。
   ```
   grant create on schema public to test;
   ```
   
2. 使用test连接test_001，重新执行创建表命令就会执行成功。
   ```
   create table test001(id varchar(2));
   ```
   
 
