
# 数据库版本升级后Navicat客户端登录实例报错1251
#### 场景描述
数据库版本升级后普通用户通过Navicat客户端登录实例报错：1251 - Client does not support authentication protocol requested by server;consider upgrading MySQL client
#### 原因分析
检查用户名的身份认证插件发现是"caching_sha2_password"，而数据库代理不支持RDS for MySQL 8.0的"caching_sha2_password"身份认证插件，导致登录报错。
#### 解决方案
- 更新Navicat驱动来解决问题。
- 将RDS for MySQL 8.0实例该用户登录的加密规则修改为"mysql_native_password"。 通过DAS执行**select plugin from mysql.user where user="** *用户名* **";**修改身份认证插件解决问题。
  
 
