
# mysqldump导出数据报错权限不足
#### 案例一
mysqldump使用指定用户导出数据库数据时，报错：Access denied; you need (at least one of) the PROCESS privilege(s)
- 原因分析：mysqldump使用指定用户导出数据时，需要赋予PROCESS权限。
- 解决方案：使用管理员账户给相应用户授予PROCESS权限。
  ```
  GRANT SELECT, PROCESS  ON *.* TO '<username>'@'<host>';
  FLUSH PRIVILEGES;
  ```
  
 
#### 案例二
mysqldump导出数据时报错：Access denied; you need (at least one of) the RELOAD privilege(s) for this operation (1227)
- 原因分析：使用具有RELOAD权限的用户执行mysqldump。
- 解决方案：使用DAS授予当前用户RELOAD全局权限。
  ```
  GRANT RELOAD ON *.* TO '<username>'@'<host>';
  FLUSH PRIVILEGES;
  ```
  
 
#### 案例三
mysqldump导出数据时报错： Access denied; you need (at least one of) the LOCK TABLES privilege(s) for this operation (1227)mysqldump
- 原因分析：使用具有LOCK TABLES权限的用户执行mysqldump。
- 解决方案：授予当前用户LOCK TABLES权限。
  ```
  GRANT LOCK TABLES ON DATABASE.* TO '<username>'@'<host>';
  FLUSH PRIVILEGES;
  ```
  
 
