
# 隔离主机并解除隔离后，任务执行失败
#### 用户问题
隔离主机并解除隔离后，任务执行失败。
#### 问题现象
MRS集群节点主机无响应触发主机隔离后，取消隔离并启动该节点上所有实例，NodeManager实例虽被启动，但该节点上所有Yarn容器启动失败。
查看NodeManager日志，持续报错：container-log4j.properties (Permission denied), exit code 255，导致SparkJDBCServer等依赖容器启动的服务无法正常运行。
#### 原因分析
主机无响应触发隔离后，停止NodeManager的指令因主机无响应未能成功下发，实例状态仍记录为STARTED。
取消隔离时，NodeAgent读取到STARTED状态，直接将实例启动，跳过了启动脚本中的权限修正步骤，仅将"etc_UPDATE"目录更名为"etc"目录（其中文件权限为600），导致配置文件权限异常。
#### 处理步骤
1. 管理员已排除主机的异常或故障后，登录MRS集群Manager，在"主机"界面勾选已隔离的主机，选择"更多 \> 取消隔离"，等待取消隔离完成。
2. 在"主机"页面单击已取消隔离的主机名称，单击"启动所有实例"，根据界面提示进行启动。
3. 选择"集群 \> 服务 \> Yarn \> 实例"，勾选与已取消隔离主机名称一致的NodeManager实例，选择"更多 \> 重启实例"，根据界面提示重启该节点上的NodeManager实例。
4. 手动提交作业，观察NodeManager日志确认Yarn容器启动正常。
 
