
# HDFS进入安全模式导致HBase服务异常，退出安全模式后HBase如何快速恢复
#### 问题现象
MRS 3.5.0及之后版本，HDFS进入安全模式后导致HBase服务异常，退出安全模式后HBase如何快速恢复？
#### 原因分析
HDFS进入安全模式后HBase服务异常，导致meta表下线；HDFS退出安全模式后，下线的meta表未上线，查看RegionServer日志存在"No namenode available to invoke create /hbase/WALs/*xxxx*.meta"报错。
由于meta表在HDFS故障恢复后的上线过程中无法记录上线状态，导致meta表无法正常上线，且Manager实例健康检查自动恢复重试存在重试次数限制，最终导致meta表上线失败。因此，HDFS退出安全模式后，需要手动介入进行恢复。
#### 处理步骤
1. 确认HDFS已解决相关异常问题，退出安全模式。
2. 登录FusionInsight Manager页面，选择"集群 \> 服务 \> HBase"，在概览界面选择"更多 \> 重启服务"，输入当前用户密码并单击"确定"，手动重启HBase服务，触发meta表重新上线。
 
