
# ClickHouse数据导入失败，报错Table is in readonly mode
#### 问题现象
从Hive导数据到ClickHouse，出现报错"Table is in readonly mode(zookeeper path：......)"，数据导入任务失败。
#### 原因分析
- ZooKeeper存在故障导致进入只读模式。
- 环境上执行过设置表只读模式的SQL语句： ALTER TABLE {table_name} MODIFY SETTING only_allow_select_statement = true
  
- ClickHouse集群正在执行数据迁移、一键均衡、退服缩容等操作。
 
#### 解决办法
1. 在问题节点执行以下命令，检查readonly mode table是否存在。
   ```
   select database,table from system.replicas where is_readonly;
   ```
   
2. 查看ClickHouse Server日志，若是由于大量写入后台数据导致的readonly mode，当操作结束后会自动恢复，此时需要对数据写入进行优化。
 
