
# 访问组件WebUI页面报500异常
#### 用户问题
访问组件WebUI页面报500异常。
#### 问题现象
访问组件WebUI页面报500异常。报错如下：
```
HTTP ERROR 500 java.io.IOException: Service connectivity error.
```
#### 原因分析
出现该异常可能都是由于Knox线程数不足。
#### 处理步骤
1. 以**root**用户分别登录OMS主节点和备节点。
2. 在主备OMS节点的gateway-site.xml文件中增加以下配置，适当增加线程池。 
   **vi /opt/knox/conf/gateway-site.xml**
   ```
   <property>
   <name>gateway.httpclient.maxConnections</name>
   <value>64</value>
   </property>
   ```
   
   
3. 以**omm** 用户登录主OMS节点，执行以下命令重启knox进程。
   
   **sh /opt/knox/bin/restart-knox.sh**
   
   
4. 等待五分钟，查看是否可以正常访问组件WebUI页面。 
   - 是，处理完毕。
   
   - 否，请联系运维人员进行处理。
   
   
   
   
 
