
# 通过专线访问Manager页面方式出现503报错
#### 问题现象
通过专线方式访问Manager界面，出现503报错：当前无法使用此页面。
#### 原因分析
随着任务量的增大或者任务并发较高，有可能会导致Executor内存不足，进而导致访问Manager异常。
#### 处理步骤
1. 通过**root** 用户登录Master1或Master2其中任意一节点，执行以下命令切换到**omm** 用户。
   **su - omm**
   
2. 执行以下命令，修改"catalina.sh"脚本。 **vim /opt/executor/bin/catalina.sh**
   搜索"JAVA_OPTS" ，找到类似JAVA_OPTS="-Xms1024m -Xmx4096m"的配置，将其值根据需要进行修改，保存修改。
   
3. 重启manager-executor进程，该进程在Master1和Master2节点上为主备部署，同一时刻只有一个节点上运行该进程，首先确认节点上是否有该进程，如果有该进程则进行重启操作。
   1. 分别登录Master1节点和Master2节点，执行以下命令确认当前节点是否存在该进程。当有输出时则进程存在。 **ps -ef \| grep "/opt/executor" \| grep -v grep**
      
   
   2. 重启命令如下。 **sh /opt/executor/bin/shutdown.sh**
      **sh** **/opt/executor/bin/startup.sh**
      
    
4. 重新访问Manager页面。
 
