
# 由于HDFS块丢失导致DataNode退服失败
#### 问题描述
在退服DataNode过程中，一直提示退服失败。
#### 原因分析
1. 查看退服失败报错日志，日志中显示总计1564个块，有一个块一直没法被备份。 ![](https://support.huaweicloud.com/trouble-mrs/zh-cn_image_0000001386600834.png "点击放大")
   
2. 登录集群Master节点，进入HDFS客户端，执行**hdfs fsck /** 命令查看损坏的块，并记录文件路径。
   例如：/tmp/hive-scratch/omm/_tez_session_dir/*xxx* -resources/*xxx*.jar。
   并且HDFS状态为"CORRUPT"
   ![](https://support.huaweicloud.com/trouble-mrs/zh-cn_image_0000001437198637.png "点击放大")
   
 
#### 处理步骤
1. 请确认该损坏的块是否可以删除。 
   - 是，执行[2]。
   
   - 否，请联系技术支持。
   
   
   
   
2. 执行以下命令进入HDFS客户端。
   
   **cd** *HDFS客户端安装目录*
   **source bigdata_env**
   **kinit** *业务用户*
   
   
3. 执行以下命令删除之前记录的损坏的块。 
   **hdfs dfs -rm -skipTrash** */tmp/hive-scratch/omm/_tez_session_dir/xxx-resources/* *xxx* *.jar*
   
   
4. 执行命令查看HDFS状态是否恢复为"HEALTHY"。 
   **hdfs fsck /**
   ![](https://support.huaweicloud.com/trouble-mrs/zh-cn_image_0000001386600510.png "点击放大")
   
   
5. 再次执行DataNode退服操作。
 
