
# mapred-default.xml文件解析异常导致WebHCat启动失败
#### 用户问题
MRS的Hive服务故障，重新启动后，Master2节点上的HiveServer和WebHCat进程启动失败，Master1节点进程正常。
#### 原因分析
登录Master2节点，查看"/var/log/Bigdata/hive/hiveserver/hive.log"日志，发现HiveServer一直加载"/opt/Bigdata/\*/\*_HiveServer/etc/hive-site.xml"；查看HiveServer退出时的"/var/log/Bigdata/hive/hiveserver/hiveserver.out"日志，发现解析"mapred-default.xml"文件异常。
#### 处理步骤
1. 登录Master2节点，使用以下命令查找"mapred-default.xml"所在路径： 
   **find /opt/ -name 'mapred-default.xml'**
   查询到该配置文件在"/opt/Bigdata/\*/\*_WebHCat/etc/"目录下面，且该文件内容为空。
   
   
2. 登录到Master1节点，将"/opt/Bigdata/\*/\*_WebHCat/etc/mapred-default.xml"文件拷贝到Master2节点，并修改文件的属组为"omm:wheel"。
3. 登录Manager，重启异常的HiveServer和WebHCat实例。
 
