
# RegionServer剩余内存不足导致HBase服务启动失败
#### 用户问题
RegionServer剩余内存不足导致HBase服务启动失败。
#### 原因分析
RegionServer启动时节点剩余内存不足，导致无法启动实例。排查步骤如下：
1. 登录Master节点，到"/var/log/Bigdata"查找HBase相关日志，HMaster的日志中报错"connect regionserver timeout "。
2. 登录到[1]中HMaster连接不上的RegionServer节点，到"/var/log/Bigdata"查找HBase相关日志，RegionServer报错"error='Cannot allocate memory'(errno=12)"。
3. 根据[2]报错判断由于RegionServer内存不足导致RegionServer启动失败。
 
#### 处理步骤
1. 登录报错的RegionServer节点，执行以下命令查看节点剩余内存： 
   **free -g**
   
   
2. 执行**top**命令查看节点内存使用情况。
3. 根据**top** 提示结束内存占用多的进程（内存占用多并且非MRS自身组件的进程），并重新启动HBase服务。
   
   ![](https://support.huaweicloud.com/trouble-mrs/public_sys-resources/note_3.0-zh-cn.png)
   集群的Core节点除了MRS组件运行占用外，Yarn上的作业还会被分配到节点运行，占用节点内存。若是由于Yarn作业占用内存多导致组件无法正常启动时，建议扩容Core节点。
   
   
 
