
# 通过Yarn WebUI查看队列信息时提示"ERROR 500"错误
#### 问题背景与现象
在Yarn使用Capacity调度器时，单击Yarn WebUI页面的队列名称时，系统上报"ERROR 500"的错误。
```
HTTP ERROR 500 javax.servlet.ServletException: javax.servlet.ServletException: java.lang.IllegalArgu mentException:
Illegal character in queryat index 81: https://XXX:20026/Yarn/ResourceManager/21/cluster/scheduler?
openQueues= ^default$
```
#### 原因分析
页面链接无法识别符号"\^"，导致页面访问失败。
#### 处理步骤
1. 登录Manager页面，选择"集群 \> 服务 \> Yarn \> 配置 \> 全部配置"。
2. 在搜索框搜索"yarn.resourcemanager.webapp.pagination.enable"。
3. 如果该参数值为"true"（默认为"true"），请修改为"false"，并保存配置。
4. 在Yarn服务页面选择"实例"页签，勾选所有的ResourceManager实例，选择"更多 \> 滚动重启实例"，等待实例启动完成。
 
