
# Hive执行insert into命令报用户权限不足
#### 用户问题
用户在Beeline命令行执行insert into命令报错：
```
INFO  : Concurrency mode is disabled, not creating a lock manager
Error: Error while processing statement: FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.mr.MapRedTask. org.apache.hadoop.yarn.exceptions.YarnException: Failed to submit application_xxx to YARN : User xxx cannot submit application application_xxx to queue root.default. ACL check failed. (state=08S01,code=1)
```
#### 原因分析
当前提交任务的用户不具备Yarn对应队列的权限。
#### 处理步骤
1. 为当前用户配置Yarn队列的权限。 
   - 在Manager界面为当前用户绑定对应权限的角色，例如：default，详细操作请参考[修改用户信息](https://support.huaweicloud.com/usermanual-mrs/admin_guide_000138.html)章节。
   
   - 若Hive启用了Ranger鉴权，也可以参考[添加Yarn的Ranger访问权限策略](https://support.huaweicloud.com/cmpntguide-mrs/mrs_01_1859.html)章节设置当前用户在指定Yarn队列提交任务的权限。
   
   
   
   
2. 权限配置生效后，重新执行命令。
 
