
# HiveServer和HiveHCat进程故障
#### 用户问题
客户集群HiveServer和WebHCat进程状态均为故障。
#### 问题现象
客户MRS集群Master2节点上的HiveServer和WebHCat进程状态显示为故障，重启之后仍为故障状态。
#### 原因分析
在Manager界面单独启动故障的HiveServer进程，登录后台查找hiveserver.out日志中对应时间点的报错，报错信息为：error parsing conf mapred-site.xml和Premature end of file。然后重启WebHCat也发现同样报错，原因即为解析mapred-site.xml文件错误。
#### 处理步骤
1. 以**root**用户登录Master2节点。
2. 执行find / -name 'mapred-site.xml'命令获取mapred-site.xml文件所在位置。
   - HiveServer对应路径为"/opt/Bigdata/*集群版本*/1_13_HiveServer/etc/mapred-site.xml"。
   
   - WebHCat对应路径为"/opt/Bigdata/*集群版本*/1_13_WebHCat/etc/mapred-site.xml"。
    
3. 确认mapred-site.xml文件是否有异常，该案例中该配置文件内容为空导致解析失败。
4. 修复mapred-site.xml文件，将Master1节点上对应目录下的配置文件用**scp**命令拷贝到Master2节点对应目录替换原文件。
5. 执行chown omm:wheel mapred-site.xml命令更改所属组和用户。
6. 在Manager界面重启故障的HiveServer和WebHCat进程，恢复正常。
 
