
# 修改hostname后导致WebHCat启动失败
#### 问题背景与现象
用户修改hostname导致WebHCat启动失败。
查看对应节点WebHCat启动日志（ /var/log/Bigdata/hive/webhcat/hive.log），发现报如下错误：
![](https://support.huaweicloud.com/trouble-mrs/zh-cn_image_0264281574.png "点击放大")
#### 原因分析
1. MRS WebHCat角色的服务端账户中涉及到hostname，如果安装完集群后再修改hostname，就会导致启动失败。
2. "/etc/hosts"中配置了一对多或者多对一的主机名和IP对应关系，导致在执行**hostname** 和**hostname -i**获取不到正确的IP和hostname。
 
#### 解决办法
1. 将修改了节点的hostname全部修改为集群初始的hostname。
2. 排查WebHCat所在节点的"/etc/hosts"是否配置正确。
3. 重启WebHCat。
 
