
# MRS配置跨集群互信失败
#### 问题背景与现象
MRS 1.8.2之前的版本和MRS 1.8.2\~2.x版本的两个集群之间跨集群互信不通。
#### 原因分析
配置跨集群互信后，互信的两个集群均会增加用户"krbtgt/*本集群域名* @*外部集群域名* "、"krbtgt/*外部集群域名* @*本集群域名*"，由于两个版本集群的用户默认密码不一致导致跨集群互信配置失败。
#### 处理步骤
- **若未配置互信场景：**
  1. 配置互信前，登录MRS 1.8.2\~2.x版本的集群上的Master节点。
  
  2. 修改所有Master节点上的"/opt/Bigdata/om-0.0.1/sbin/addRealm.sh"脚本中的add_cross_realm_princ方法中的**local cross_realm_account_pwd="${DEFAULT_CROSS_REALM_PWD}"** 为**local cross_realm_account_pwd="${DEFAULT_PWD}"** （位于脚本的1001行）。
     ![](https://support.huaweicloud.com/trouble-mrs/public_sys-resources/note_3.0-zh-cn.png)
     为MRS 1.8.2\~2.x版本的集群上的所有Master节点执行步骤[1]\~[2]。
     
  
  3. 再参考[配置跨集群互信](https://support.huaweicloud.com/usermanual-mrs/mrs_01_0354.html)配置。
  
  4. 检查互信是否成功。
     - 成功，则配置结束。
     
     - 失败，请刷新客户端配置后再检查互信是否成功，若依然不成功请联系运维人员处理。
      
   
- **若已经配置互信场景：**
  1. 登录MRS 1.8.2\~2.x版本的集群上的Master节点。
  
  2. 执行以下命令并输入密码，登录Kerberos客户端。 **/home/omm/kerberos/bin/kadmin -p kadmin/admin**
     
  
  3. 执行listprincs并按回车，查询用户信息。 ![](https://support.huaweicloud.com/trouble-mrs/zh-cn_image_0264281816.png "点击放大")
     
  
  4. 执行**delprinc** 命令删除用户"krbtgt/*本集群域名* @*外部集群域名* "、"krbtgt/*外部集群域名* @*本集群域名* "。
     ![](https://support.huaweicloud.com/trouble-mrs/zh-cn_image_0264281923.png "点击放大")
     
  
  5. 使用**quit**命令退出Kerberos客户端。
  
  6. 修改Master节点上的/opt/Bigdata/om-0.0.1/sbin/addRealm.sh脚本中的add_cross_realm_princ方法中的**local cross_realm_account_pwd="${DEFAULT_CROSS_REALM_PWD}"** 为**local cross_realm_account_pwd="${DEFAULT_PWD}"**（位于脚本的1001行）。
  
  7. 登录MRS Manager页面，选择"服务管理"。
  
  8. 选择"更多 \> 同步配置"。
  
  9. 在弹出窗口勾选"重启配置过期的服务或实例。"，并单击"确定"，重启配置过期的服务。
     同步配置时会调用addRealm.sh脚本添加krbtgt用户。
     ![](https://support.huaweicloud.com/trouble-mrs/public_sys-resources/note_3.0-zh-cn.png)
     为MRS 1.8.2\~2.x版本的集群上的所有Master节点执行步骤[1]\~[9]。
     
  
  10. 检查互信是否成功，若依然不成功，请联系运维人员处理。
   
 
