
# Hive服务启动失败
Hive服务启动失败最常见的原因是metastore实例无法连接上DBservice，可以查看metastore日志中具体的错误信息。
#### 可能原因
1. DBservice没有初始化好Hive的元数据库hivemeta。
2. DBservice的浮动IP配置有误，导致metastore节点IP无法正确连接浮动IP，或者是在与该ip建立互信的时候失败导致metastore启动失败。
 
#### 处理步骤1
1. 执行以下命令： 
   **source /opt/Bigdata/MRS_** *XXX* **/install/dbservice/.dbservice_profile**
   **gsql -h** *DBservice浮动IP地址* **-p 20051 -d hivemeta -U** *hive* **-W** *hive用户密码*
   
   
2. 如果不能正确进入交互界面，说明数据库初始化失败。如果报如下错误说明在DBservice所在的节点的配置文件可能丢失了hivemeta的配置。 
   ```
   org.postgresql.util.PSQLException: FATAL: no pg_hba.conf entry for host "192.168.0.146", database "HIVEMETA"。
   ```
   
   
3. 编辑"/srv/BigData/dbdata_service/data/pg_hba.conf"，在文件最后面追加**host hivemeta hive 0.0.0.0/0 sha256**配置。
4. 执行**source /opt/Bigdata/MRS_** *XXX* **/install/dbservice/.dbservice_profile**命令配置环境变量。
5. 执行**gs_ctl -D $GAUSSDATA reload** **#**命令使修改后的配置生效。
 
#### 处理步骤2
DBservice的浮动IP配置需要同网段内没有被使用过的IP，也就是在配置前ping不通的IP，请修改DBService浮动IP配置。
