
# Storm UI查看信息时显示Internal Server Error
#### 问题背景与现象
使用MRS版本安装集群，主要安装ZooKeeper、Storm。
通过MRS Manager中的Storm Status页面UI连接访问信息时显示如下信息：
```
Internal Server Error
org.apache.thrift7.transport.TTransportException: Frame size (306030) larger than max length (1048576)!
```
#### 可能原因
- Storm服务中Nimbus异常。
- Storm集群信息较多超过系统默认Thrift传输大小的设置。
 
#### 原因分析
1. 查看Storm服务状态及监控指标：
   - MRS Manager界面操作：登录MRS Manager，依次选择"服务管理 \> Storm"，查看当前Storm状态，发现状态为良好，且监控指标内容显示正确。
   
   - FusionInsight Manager界面操作：登录FusionInsight Manager，选择"集群 \> 服务 \> Storm"，查看当前Storm状态，发现状态为良好，且监控指标内容显示正确。
    
2. 选择"实例"页签，查看Nimbus实例状态，显示正常。

3. 查看当前Storm集群thrift相关配置，发现nimbus.thrift.max_buffer_size参数配置为1048576（1M）。
4. 上述配置和异常信息中信息一致，说明当前配置的Thrift的buffer size小于集群信息所需的buffer size。
 
#### 解决方法
调整Storm集群中Thrift的Buffer Size大小，具体大小根据错误信息进行实际调整。
1. 进入Storm服务参数配置界面。 
   - MRS Manager界面操作：登录MRS Manager页面，选择"服务管理 \> Storm \> 服务配置"，"参数类别"选择"全部配置"。
   
   - FusionInsight Manager界面操作：登录FusionInsight Manager，选择"集群 \> 服务 \> Yarn"，单击"配置"，选择"全部配置"。
   
   
   
   
2. 修改nimbus.thrift.max_buffer_size参数为10485760（10M）。
3. 保存配置，勾选"重新启动受影响的服务或实例"并单击"确定"重启服务。
 
