
# 参数不合理导致HBase启动失败
#### 问题现象
修改部分参数后，无法正常启动HBase。
#### 原因分析
1. 查看HMaster日志（/var/log/Bigdata/hbase/hm/hbase-omm-xxx.log）显示，hbase.regionserver.global.memstore.size + hfile.block.cache.size总和大于0.8导致启动不成功，因此需要调整参数配置值总和低于0.8。 ![](https://support.huaweicloud.com/trouble-mrs/zh-cn_image_0276002938.png "点击放大")
   
2. 查看HMaster和RegionServer的out日志（/var/log/Bigdata/hbase/hm/hbase-omm-xxx.out/var/log/Bigdata/hbase/rs/hbase-omm-xxx.out），提示Unrecognized VM option。
   ```
   Unrecognized VM option 
   Error: Could not create the Java Virtual Machine.
   Error: A fatal exception has occurred. Program will exit.
   ```
   检查GC_OPTS相关参数存在多余空格，如-D sun.rmi.dgc.server.gcInterval=0x7FFFFFFFFFFFFFE。
   
 
#### 解决办法
1. 针对memstore、cache修改配置参数后，重启HBase服务成功。
2. 针对GC_OPTS配置错误，修改参数后重启HBase服务成功。
 
