
# MRS备份任务执行失败
#### 问题现象
MRS的备份任务总是执行失败。
#### 原因分析
备份目录软链接到系统盘，系统盘满了之后备份任务失败。
#### 处理步骤
1. 检查备份目录是否软链接到系统盘。 
   1. 以**root**用户登录集群主备Master节点。
   
   2. 执行df -h命令查看磁盘情况，检查系统盘的存储情况。
   
   3. 执行 ll /srv/BigData/LocalBackup命令， 查看备份目录是否软连接到**/opt/Bigdata/LocalBackup** 。
      检查备份文件是否软链接到系统盘且系统盘空间是否足够。如果软链接到系统盘且系统盘空间不足，请执行[步骤2]。如果否，说明不是由于系统盘空间不足导致，请联系技术服务。
      
   
   
   
   
2. 将历史备份数据移到数据盘的新目录中。
   
   1. 以**root**用户登录Master节点。
   
   2. 执行su - omm命令，切换到omm用户。
   
   3. 执行rm -rf /srv/BigData/LocalBackup命令，删除备份目录软连接。
   
   4. 执行mkdir -p /srv/BigData/LocalBackup命令，创建备份目录。
   
   5. 执行mv /opt/Bigdata/LocalBackup/* /srv/BigData/LocalBackup/命令，将历史备份数据移到新目录。
   
   
   
   
3. 重新执行备份任务。
 
