
# 获取Kafka Topic时报错"InvalidReplicationFactorException"
#### 问题现象
运行Kafka客户端获取Topic时报错，报错内容如下：
```
ERROR org.apache.kafka.common.errors.InvalidReplicationFactorException: Replication factor: 2 larger than available brokers: 0.
```
#### 原因分析
由特殊字符导致获取的ZooKeeper地址变量错误。
#### 处理步骤
1. 登录任意一个Master节点。
2. 执行以下命令，查看ZooKeeper地址的变量信息。
   
   ```
   cat 客户端安装目录/Kafka/kafka/config/server.properties |grep '^zookeeper.connect ='
   ```
   
   
3. 重新运行Kafka获取Topic，其中从[2]中获取的变量不要添加任何字符。
 
