
# 通过spark-beeline指定location到OBS建表失败
#### 问题现象
对接OBS ECS/BMS集群，spark-beeline登录后，指定location到OBS建表报错失败。
图1错误信息   
![](https://support.huaweicloud.com/trouble-mrs/zh-cn_image_0000001676908198.png "点击放大")
#### 原因分析
HDFS上ssl.jceks文件权限不足，导致建表失败。
![](https://support.huaweicloud.com/trouble-mrs/zh-cn_image_0000001724747681.png "点击放大")
#### 处理步骤
1. 使用**omm** 用户登录Spark2x所在节点，执行如下命令：
   ```
   vi ${BIGDATA_HOME}/FusionInsight_Spark2x_xxx/install/FusionInsight-Spark2x-*/spark/sbin/fake_prestart.sh
   ```
   
2. 将"eval "${hdfsCmd}" -chmod 600 "${InnerHdfsDir}"/ssl.jceks \>\> "${PRESTART_LOG}" 2\>\&1"修改成"eval "${hdfsCmd}" -chmod 644 "${InnerHdfsDir}"/ssl.jceks \>\> "${PRESTART_LOG}" 2\>\&1"。
3. 重启SparkResource实例。
 
