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Windows80端口被占用怎么办?

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更新时间: 2019/11/06 GMT+08:00

问题描述

当Windows系统云服务器启动Tomcat时报错,提示80端口被占用。

可能原因

次应用使用的端口被其他程序或者病毒木马占用

  1. 使用netstat –ano | find “80” 看到占用端口的进程ID是4。

    请根据实际情况修改端口。

    图1 查看占用端口的进程ID
  1. 执行tasklist /svc | find “4” 看到的是系统进程。

    请根据实际情况修改端口。

    图2 系统进程

通过查看发现80端口被系统System进程占用

处理方法

此操作可能需要关闭正在运行的业务或者重启云服务器。

方法一

  1. 以管理员身份运行cmd,输入net stop http
  2. 若需要停止对应服务,则选择“Y
  3. 执行sc config http start=disabled

方法二:

  1. 在cmd下运行regedit打开注册表
  2. 找到注册表HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\services\\HTTP,修改Start,将其改为0
  3. 重启云服务器。
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