
# 云服务器新内核启动失败如何设置使用第二内核启动
#### 操作场景
本节操作介绍云服务器新内核启动失败时如何设置使用第二内核启动。
本节操作适用于CentOS EulerOS操作系统，且系统内安装至少两个内核。
#### CentOS 6操作系统
1. 登录控制台，重启云服务器，单击"远程登录"。
2. 在出现Booting CentOS界面时，按任意键，进入内核选择界面。
   图1Booting CentOS   
   ![](https://support.huaweicloud.com/trouble-ecs/zh-cn_image_0256641552.png "点击放大") 
3. 内核选择界面出现时按下键将光标移至第二内核，然后按回车键进行启动。 ![](https://support.huaweicloud.com/trouble-ecs/zh-cn_image_0188650244.png "点击放大")
   
4. 待系统启动后，执行以下命令设置默认启动内核为第二内核。 **sed 's/default=0/default=1/' /boot/grub/grub.conf -i**
   ![](https://support.huaweicloud.com/trouble-ecs/public_sys-resources/note_3.0-zh-cn.png)
   default默认值为 0（代表从/boot/grub/grub.conf文件中kernel菜单中第一个，从上往下依次是 0，1，2 等）。
   
 
#### CentOS 7/EulerOS操作系统
1. 登录控制台，重启云服务器，单击"远程登录"。
2. 在出现内核选择界面时，按下键，将光标移至第二内核，按回车键。 ![](https://support.huaweicloud.com/trouble-ecs/zh-cn_image_0188460781.png "点击放大")
   
3. 待系统启动后，执行以下命令设置默认启动内核为第二内核。 **grub2-set-default 1**
   
 
