
# Linux启动sshd服务出现/var/empty/sshd无法访问的解决方案
#### 问题现象
Linux云服务器启动sshd服务失败，出现/var/empty/sshd无法访问的问题。
![](https://support.huaweicloud.com/trouble-ecs/zh-cn_image_0179518546.png "点击放大")
#### 适用场景
本节操作适用于CentOS7/EulerOS系统，其他Linux系统可能存在差异。
#### 场景一：/var/empty/sshd属主非root导致sshd启动失败
1. sshd启动失败，查看journal日志，提示/var/empty/sshd must be owned by root。 **journalctl -xe**
   ![](https://support.huaweicloud.com/trouble-ecs/zh-cn_image_0179518889.png "点击放大")
   
2. 查看/var/empty/sshd文件属主信息 **ll /var/empty/sshd**
   ![](https://support.huaweicloud.com/trouble-ecs/zh-cn_image_0179520107.png "点击放大")
   如上图所示，由于/var/empty/sshd目录属主非root用户导致sshd服务启动失败。
   
3. 修改/var/empty/sshd属主，及其权限。 **chown -R root.root /var/empty/sshd**
   **chmod -R 711 /var/empty/sshd**
   
4. 重启sshd服务，执行： **systemctl restart sshd**
   
 
#### 场景二：/var/empty/sshd文件缺失导致sshd启动失败
1. 执行以下命令，查看服务失败原因。 **journalctl -xe**
   ![](https://support.huaweicloud.com/trouble-ecs/zh-cn_image_0179538071.png "点击放大")
   
2. 从上图可知由于/var/empty/sshd缺失导致sshd启动失败，执行以下命令，手动创建该目录。 **mkdir -p /var/empty/sshd**
   
3. 重启sshd服务。 **systemctl restart sshd**
   
 
