
# 执行业务报错，提示ERROR: Session used memory xxx Kbytes is beyond the limitation (xxx Kbytes)
#### 问题现象
业务执行报错，如下提示。
```
ERROR: dn_6009_6010: dn_6005_6006: Session used memory 20977664 Kbytes is beyond the limitation (20971520 Kbytes)
```
#### 原因分析
当前使用内存超过GUC参数[query_max_mem](https://support.huaweicloud.com/devg-dws/dws_04_0893.html)（用于控制执行作业所能够使用的最大内存）设置的值。
#### 处理方法
1. 连接数据库，执行以下命令查询query_max_mem当前值。 
   ```
   SHOW query_max_mem;
   ```
   
   
2. 根据业务需求，调整当前会话session的query_max_mem为更大值。 
   ```
   SET query_max_mem= '30GB';
   ```
   
   
3. 该作业涉及的表都执行一次analyze。 
   ```
   ANALYZE {table name};
   ```
   
   
 
