
# 全量或增量阶段失败报错，关键词"Access denied for user \*\*\*"
#### 场景描述
全量或增量阶段，DRS迁移或同步任务报错，日志提示信息：service %s failed, cause by: Unable to connect to DBMS: url=\*\*\*?useUnicode=true\&allowLoadLocalInfile=false\&characterEncoding=UTF-8\&connectTimeout=5000\&useSSL=false\&allowPublicKeyRetrieval=true\&verifyServerCertificate=false\&serverTimezone=UTC user=%s, Caused by: Access denied for user %s
#### 可能原因
访问源库或目标库时建立连接失败。
#### 解决方案
1. 检查源库或目标库运行状态是否正常。
2. 检查DRS任务连接源库或目标库的密码是否正确。
3. 检查DRS实例和源库或目标库之间的网络是否能够连通。
4. 检查源库或目标库远程访问或者访问白名单是否对DRS实例的IP放通。
 
