
# 源数据库索引长度检查
#### Oracle-\>MySQL、Oracle-\>TaurusDB迁移、同步场景
表1源数据库索引长度检查 
|          **预检查项**           |                                                             源数据库存在超过目标库索引列长度限制的索引。                                                             |
|---|---|
| ****描述****                  | 源数据库存在超过目标库索引列长度限制的索引，则导致迁移失败。                                                                                                                 |
| ****不通过提示** **及**处理建议****** | **不通过原因：**源数据库存在超过目标库索引列长度限制的索引。 **处理建议**：1. 在迁移对象中去除这张表。2. 修改索引长度。 |
   
#### MySQL迁移、同步、灾备场景
表2源数据库索引长度检查 
|          **预检查项**           |                                                                           源数据库存在超过目标库索引列长度限制的索引。                                                                            |
|---|---|
| ****描述****                  | 源数据库存在超过目标库索引列长度限制的索引，则导致迁移失败。                                                                                                                                              |
| ****不通过提示** **及**处理建议****** | **不通过原因：**源数据库存在超过目标库索引列长度限制的索引。 **处理建议**：将目标库innodb_large_prefix参数修改为ON，或者返回上一步迁移设置中，重新选择要迁移的表。 |
   
