
# 插件不兼容导致集群不可用
#### 问题现象
安装自定义插件后重启集群，"集群状态"变为"不可用"。
单击集群名称进入集群详情页面，选择"日志管理 \> 日志查询"，可见日志内容存在明显的关于插件的报错"fatal error in thread \[main\], exitingjava.lang. NoClassDefFoundError: xxx/xxx/.../xxxPlugin at ..."。
图1节点报错日志示例   
![](https://support.huaweicloud.com/trouble-css/figure/zh-cn_image_0000001981581429.png "点击放大")
![](https://support.huaweicloud.com/trouble-css/public_sys-resources/caution_3.0-zh-cn.png)
CSS服务已下线自定义插件功能，但历史版本的集群可能还装有自定义插件，只有这类集群可能出现该故障。
#### 原因分析
可能是安装的自定义插件与CSS集群版本不兼容，导致Elasticsearch进程无法正常启动。
#### 处理步骤
1. 在集群管理页面，单击不可用的集群名称，进入集群详情页面。
2. 选择"集群配置 \> 插件管理"。
3. 选择"自定义插件列表"页签，确认是否继续使用该自定义插件。
   - 是，删除插件后重新安装。
     1. 在自定义插件操作列表，卸载并删除插件。
     
     2. 根据节点日志的报错信息解决插件存在的问题，无法自行解决时可联系技术支持。
     
     3. 插件问题解决后，在自定义插件操作列表，上传并安装插件。当"插件状态"为"已安装，待重启集群后生效"时，表示插件安装成功。
      
   
   - 否，删除插件。 在自定义插件操作列表，卸载并删除插件。
     
    
4. 在页面右上角单击"重启"，集群将重启。
5. 待集群重启成功后，集群恢复可用。
 
