
# Elasticsearch集群报错：unassigned shards all indices
#### 问题描述
Elasticsearch集群报错"unassigned shards all indices"，集群状态为red。
#### 原因分析
当前集群存在未分配的shard。
#### 解决方案
1. 登录Kibana。
   1. 登录[云搜索服务管理控制台](https://console.huaweicloud.com/elasticsearch/)。
   
   2. 在左侧导航栏，选择"集群管理 \> Elasticsearch"。
   
   3. 在集群列表，选择目标集群，单击操作列的"Kibana"，登录Kibana。
   
   4. 在Kibana左侧导航栏选择"Dev Tools"，进入操作页面。 控制台左侧是命令输入框，其右侧的三角形图标为执行按钮，右侧区域则显示执行结果。
      
    
2. 执行如下命令，尝试重新分配未能成功分配的分片。
   ```
   POST  /_cluster/reroute?retry_failed=true
   ```
   
 
