
# X-pack参数配置导致集群不可用
#### 问题现象
"集群状态"为"不可用"，集群的"任务状态"为"配置错误，重启失败"。
图1集群配置错误   
![](https://support.huaweicloud.com/trouble-css/figure/zh-cn_image_0000001981501297.png "点击放大")
#### 原因分析
集群可能配置了X-pack相关的自定义参数导致集群不可用。CSS服务不支持X-pack功能。
#### 处理步骤
1. 在集群管理页面，单击不可用的集群名称，进入集群详情页面。
2. 选择"集群配置 \> 参数配置"。
3. 根据集群类型选择"OpenSearch配置"或"Elasticsearch配置"页签。
4. 展开"自定义"模块，查看是否存在X-pack相关的自定义参数。
   ![](https://support.huaweicloud.com/trouble-css/public_sys-resources/note_3.0-zh-cn.png)
   X-pack相关的自定义参数示例：
   - "xpack.security.enabled": "true"
   
   - "xpack.security.http.ssl.enabled": "true"
   
   - "xpack.security.http.ssl.keystore.path": "http.p12"
    
   - 是，则执行下一步。
   
   - 否，联系技术支持定位参数配置问题。
    
5. 删除X-pack相关的自定义参数。
   1. 单击"编辑"，在需要删除的参数右侧单击"删除"。
   
   2. 单击"保存"，在弹窗中勾选"参数修改后需要手动重启才能生效"，单击"确定"。 当下方的参数修改列表显示"作业状态"为"成功"时，表示修改保存成功。
      
   
   3. 在页面右上角单击"重启"，集群将重启以使配置更改生效。
   
   4. 集群重启成功后，集群恢复可用。
    
 
