
# 安全集群索引只读状态修改报错
#### 问题描述
安全集群磁盘使用率超过阈值后，索引会全部变为只读模式"read_only_allow_delete": "true"，导致无法再写入，需手动修改只读模式为"false"，执行如下命令：
```
PUT _settings
{
  "index": {
    "blocks": {
      "read_only_allow_delete": "false"
    }
  }
}
```
报错为：
```
{
  "error": {
    "root_cause": [
      {
        "type": "security_exception",
        "reason": "no permissions for [] and User [name=admin, roles=[admin], requestedTenant=null]"
      }
    ],
    "type": "security_exception",
    "reason": "no permissions for [] and User [name=admin, roles=[admin], requestedTenant=null]"
  },
  "status": 403
}
```
#### 原因分析
安全集群，默认有一个".opendistro_security"索引，不可执行写操作，修改索引读写模式时要忽略掉这个索引。
#### 解决方案
使用通配符进行匹配，将indexname用通配符代替。
```
PUT indexname/_settings
{
  "index": {
    "blocks": {
      "read_only_allow_delete": "false"
    }
  }
}
```
