
# Elasticsearch集群更改规格失败
#### 问题描述
执行集群更改规格操作失败，console界面报错详情如下图所示。
图1CSS.0073错误   
![](https://support.huaweicloud.com/trouble-css/figure/zh-cn_image_0000001950381920.png)
图2CSS.0011错误   
![](https://support.huaweicloud.com/trouble-css/figure/zh-cn_image_0000001981501333.png)
#### 原因分析
当前索引副本数为0，后台拦截了更改规格的请求。需要设置好副本数，再进行更改规格操作，否则会有分片丢失的风险。
#### 解决方案
设置副本参数：
```
PUT /index/_settings
{
    "number_of_replicas" : 1 //表示需要设置的副本数
}
```
