
# ECS服务器部署Logstash推送数据到CSS服务报错
#### 问题现象
ECS服务器部署Logstash，然后推送数据到云搜索服务CSS，出现错误信息如下：
```
LogStash::Outputs::ElasticSearch::HttpClient::Pool::BadResponseCodeError: Got response code '500' contacting Elasticsearch at URL 'https://192.168.xx.xx:9200/_xpack'
```
#### 原因分析
目前云搜索服务没有集成x-pack插件，自行搭建Logstash连接css服务的时候，会检查es是否启用了x-pack。
#### 处理步骤
1. 删除Logstash中的x-pack目录。
2. 修改Logstash配置文件中output模块的elasticsearch中添加配置项"ilm_enabled =\> false"。
3. 重新尝试推送数据到Elasticsearch集群。
 
