
# Elasticsearch显示CPU使用率高，导致日志无法写入
#### 问题现象
Elasticsearch在某一时间段CPU比较高，Logstash在该时刻报错"Elasticsearch Unreachable"，导致日志数据无法写入Elasticsearch集群。
#### 原因分析
由于index是单shard，压力承载于单个节点，负载过高，造成队列满后，作业被拒绝。
#### 处理步骤
1. 登录[云搜索服务管理控制台](https://console.huaweicloud.com/elasticsearch/)。
2. 在左侧导航栏，选择"集群管理 \> Elasticsearch"。
3. 在集群列表，选择目标集群名称，单击操作列的"更多 \> Cerebro"，登录Cerebro。
4. 在Cerebro中查看集群的分片数、各节点的cpu、load、heap、disk等数据指标。
5. 根据指标分析可能出现的原因，针对性优化。
   1. 增加队列数，减少拒绝作业，修改参数"write.queue_size"取值。
      1. 单击需要修改参数的集群名称，进入集群详情页面。
      
      2. 选择"集群配置 \> 参数配置 \> Elasticsearch配置"。
      
      3. 在"自定义"模块，查找"write.queue_size"参数并改大该参数值。 如果没有此参数，可以在自定义参数列进行添加。
         参数修改的详细操作指导请参见[参数配置](https://support.huaweicloud.com/usermanual-css/css_01_0080.html)章节。
         
       
   
   2. 重建索引，使分片数大于集群节点数。
    
6. 如果分片数和队列大小都满足条件，但是cpu和负载依然比较高，建议扩容节点。
 
