
# 访问CDN加速资源后返回5XX状态码
1. 测试源站的URL访问是否可以复现5xx错误，排查是否是源站异常，测试步骤详见[排查访问异常是CDN节点问题还是源站问题](https://support.huaweicloud.com/trouble-cdn/cdn_01_0151.html)。
   如果确认为源站问题，请检查您的源站配置，CDN控制台的数据可以帮助您排查部分源站问题。
   - 登录CDN控制台，左侧导航栏选择"CDN"\>"统计分析"\>"源站统计"。 ![](https://support.huaweicloud.com/trouble-cdn/zh-cn_image_0000001162269395.png "点击放大")
     
   
   - 检查带宽和流量有没有突增的情况，如果带宽突增，会导致源站压力过大，从而引发源站超时响应。此时您需要检查近期是否有资源更新，或者热点资源重新设置缓存规则。对于新发布资源和功能的情况，建议您将大文件提前预热到CDN节点，以防出现集中回源导致源站遭遇带宽瓶颈。
   
   - 检查源站是否配置缓存规则，如果源站设置了no-cache、private、no-store，CDN侧同时开启了"缓存遵循源站"功能（此功能默认关闭），CDN将无法缓存源站资源，导致所有请求回源，大量请求集中回源时也可能导致源站响应超时。缓存规则的设置详见：[如何设置缓存过期时间](https://support.huaweicloud.com/bestpractice-cdn/cdn_01_0133.html)。
   
   - 检查源站服务器网络波动，源站运营商网络故障也会导致回源超时。
   
   
   如果源站访问正常，请进行下一步排查。
   
2. **返回504状态码**
   ![](https://support.huaweicloud.com/trouble-cdn/zh-cn_image_0000001117887336.png)
   **原因：**可能是CDN回源协议与您的源站支持的协议不一致导致的。
   1. CDN回源方式"协议跟随"，即回源协议与客户端访问协议一致。
      - 如果客户端以HTTPS协议访问CDN，CDN会以HTTPS协议回源到服务器，如果您的源站服务器不支持HTTPS协议，就会响应504。
      
      - 如果客户端以HTTP协议访问CDN，CDN会以HTTP协议回源到服务器，如果您的源站服务器不支持HTTP协议，就会响应504。
      
      - 如果客户端以HTTP协议访问CDN，您在CDN侧配置了强制跳转到HTTPS，CDN会以HTTPS协议回源到服务器，如果您的源站服务器不支持HTTPS协议，就会响应504。
       
   
   2. CDN默认回源方式为"HTTP"，源站仅支持HTTPS协议访问。
   
   3. CDN回源方式为"HTTPS"，源站仅支持HTTP协议访问。
   
   
   **解决办法：** 修改CDN侧配置，匹配源站支持的访问协议。CDN默认回源方式为"HTTP"，请将回源方式修改为源站支持的协议，详见[回源方式](https://support.huaweicloud.com/usermanual-cdn/cdn_01_0194.html)。
   
3. **返回502状态码**
   - 请检查您的源站服务器是否配置了安全狗、防火墙等安全策略，拦截了CDN的回源IP。
     - 由于CDN回源时会智能分配节点访问您的源站服务器，回源的节点IP是不固定的，因此不建议您将源站服务器的回源策略设置为固定的节点IP列表，这样可能会发生回源失败的情况。
     
     - 如果您因业务需要，使用了安全狗等防护软件，请调整过于严格的安全策略，避免导致误拦截。
      
    
4. 如果以上排查仍无法解决您的问题，请您联系客服或[提交工单](https://console.huaweicloud.com/ticket/?&locale=zh-cn#/ticketindex/createIndex)处理。
 
