文档首页 > > 工具指南> DSC SQL语法迁移工具>

系统要求(DSC)

系统要求(DSC)

分享
更新时间:2021/03/09 GMT+08:00

支持的数据库

DSC支持的源数据库如表1所示。

表1 支持的源数据库

数据库名称

数据库版本

Netezza

7.0

Teradata

13.1

Oracle

11g Release 2

12c Release 1

MySQL

5.6

软件要求

操作系统要求

DSC兼容的操作系统如表2所示。

表2 兼容的操作系统

服务器

操作系统

版本

通用x86服务器

SUSE Linux Enterprise Server 11

SP1(SUSE11.1)

SP2(SUSE11.2)

SP3(SUSE11.3)

SP4(SUSE11.4)

SUSE Linux Enterprise Server 12

SP0(SUSE12.0)

SP1(SUSE12.1)

SP2(SUSE12.2)

SP3(SUSE12.3)

RHEL

6.4-x86_64(RedHat6.4)

6.5-x86_64(RedHat6.5)

6.6-x86_64(RedHat6.6)

6.7-x86_64(RedHat6.7)

6.8-x86_64(RedHat6.8)

6.9-x86_64(RedHat6.9)

7.0-x86_64(RedHat7.0)

7.1-x86_64(RedHat7.1)

7.2-x86_64(RedHat7.2)

7.3-x86_64(RedHat7.3)

7.4-x86_64(RedHat7.4)

CentOS

6.4(CentOS6.4)

6.5(CentOS6.5)

6.6(CentOS6.6)

6.7(CentOS6.7)

6.8(CentOS6.8)

6.9(CentOS6.9)

7.0(CentOS7.0)

7.1(CentOS7.1)

7.2(CentOS7.2)

7.3(CentOS7.3)

7.4(CentOS7.4)

Windows

7.0,10

其他软件要求

DSC对其他软件版本的要求如表3所示。

表3 其他软件要求

软件

用途

JDK 1.8.0_141及以上版本

用于运行DSC的软件版本。

Perl 5.8.8

用于迁移Perl文件。

Perl 5.28.2及以上版本

用于在Windows中迁移Perl文件。

此处的Perl 5.8.8为固定版本,考虑到语法兼容性,不能使用更高的版本。

分享:

    相关文档

    相关产品