文档首页 > > 工具指南> Data Studio数据库集成开发工具> 自定义Data Studio> 通用

通用

分享
更新时间: 2019/08/09 GMT+08:00

本节介绍如何自定义快捷键。

设置快捷键

可根据需要设置Data Studio快捷键。

执行如下步骤设置或修改快捷键:

  1. 从主菜单中选择“设置 > 首选项”。

    显示“首选项”对话框。

  2. 选择“快捷键”。显示“快捷键”页签。
  3. 选择要修改的快捷键,单击“修改”。
  4. 在“快捷键”文本框中输入所需快捷键。

    例如,要将“单步进入”的快捷键由“F7”改为“F6”,将光标移至文本框中,按下“F6”。

  5. 单击“确认”。显示“Data Studio即将重启”对话框。

    说明:
    • 可修改多个快捷键,然后再启动Data Studio。

  6. 单击“”重启Data Studio。如果正在进行导入、导出或执行操作,会显示“重启确认”对话框。
  7. 单击“确定”以关闭运行中的作业并重新启动应用程序,或单击“取消”以取消重启操作。

执行如下步骤删除快捷键:

  1. 从主菜单中选择“设置 > 首选项”。

    显示“首选项”对话框。

  2. 选择“快捷键”。显示“快捷键”页签。
  3. 选择要修改的快捷键,单击“取消快捷键”。
  4. 单击“确认”。显示“Data Studio即将重启”对话框。

    说明:

    可删除多个快捷键,然后再启动Data Studio。

  5. 单击“”重启Data Studio。如果正在进行导入、导出或执行操作,会显示“进程正在运行”对话框。
  6. 单击“确定”等待操作完成,或单击“强制重启”放弃现有操作。

执行如下步骤还原默认快捷键设置:

  1. 从主菜单中选择“设置 > 首选项”。

    显示“首选项”对话框。

  2. 选择“快捷键”。显示“快捷键”页签。
  3. 单击“恢复默认”。默认快捷键有关详情,请参见Data Studio右键菜单
  4. 单击“确认”。显示“Data Studio即将重启”对话框。
  5. 单击“”重启Data Studio。如果正在进行导入、导出或执行操作,会显示“进程正在运行”对话框。
  6. 单击“确定”等待操作完成,或单击“强制重启”放弃现有操作。

快捷键

与其他基于Windows的应用一样,Data Studio支持快捷键。下表列出了一些快捷键以高效使用Data Studio 提供的功能。要自定义快捷键,参见 设置快捷键
表1 Data Studio默认键盘快捷键

功能

快捷键

按升序、降序或服务器接收顺序对视图表、编辑表和查询的结果集进行排序

Alt+单击

“帮助”菜单

Alt+H

保存SQL脚本

Ctrl+S

“编辑”菜单

Alt+E

编译/执行SQL终端语句

Ctrl+Enter

查找和替换

Ctrl+F

查找上一处

Shift+F3

查找下一处

F3

重做

Ctrl+Y

从“编辑表数据”页签中复制“执行时间”和“状态”

Ctrl+Shift+K

从自动建议列表中复制数据库对象

Alt+U

打开“调用堆栈”、“断点”窗格、和“变量”窗格

Alt+V

打开SQL脚本

Ctrl+O

单步跳过

F8

单步进入

F7

单步退出

Shift+F7

单独注释/取消注释行

Ctrl+/

定位到“对象浏览器”中第一个元素

Alt+Page Up或Alt+Home

定位到“对象浏览器”中最后一个元素

Alt+Page Down或Alt+End

定位到行

Ctrl+G

断开连接

Ctrl+Shift+D

格式化(SQL、PL/SQL)

Ctrl+Shift+F

更改为大写

Ctrl+Shift+U

更改为小写

Ctrl+Shift+L

更新“编辑表数据”、“属性”和“结果”窗口中的单元格或列。单击单元格或列标题以启用此选项。

F2

关闭当前“PL/SQL Viewer”页签、“表数据查看页签”、“执行查询”页签、或“属性”页签

Shift+F4

继续PL/SQL调试操作

F9

剪切

Ctrl+X

复制“对象浏览器”或终端中修饰的对象名。从“终端”,“结果”,“查看表数据”或“编辑表数据”页签复制所选数据。

Ctrl+C

复制“结果”,“查看表数据”或“编辑表数据”页签中的数据,包含/不包含列标题和行数字。

Ctrl+Shift+C

复制“编辑表数据”页签中的查询

Ctrl+Alt+C

复制“变量”页签内容

Alt+K

复制“调用堆栈”页签内容

Alt+J

复制“断点”页签内容

Alt+Y

可视化解释计划

Alt+Ctrl+X

联机帮助(显示用户手册)

F1

模板

Alt+Ctrl+Space

切换到第一个“SQL终端”页签

Alt+S

全选

Ctrl+A

“设置”菜单

Alt+G

刷新(在“对象浏览器”区域框中)

F5

搜索对象

Ctrl+Shift+S

“调试”菜单

Alt+D

调试模板

F10

调试数据库对象

Ctrl+D

突出显示对象浏览器

Alt+X

“文件”菜单

Alt+F

新建连接

Ctrl+N

“运行”菜单

Alt+R

在“SQL终端”页签间切换

Ctrl+Page Up或Ctrl+Page Down

展开/折叠所有对象

Ctrl+M

粘贴

Ctrl+V

折叠对象浏览导航树

Alt+Q

执行

Ctrl+E

执行计划和开销

Ctrl+Shift+X

终止运行中的查询

Shift+Esc

注释/取消注释行或整段

Ctrl+Shift+/

自动建议数据库对象列表

Ctrl+Space

分享:

    相关文档

    相关产品

文档是否有解决您的问题?

提交成功!

非常感谢您的反馈,我们会继续努力做到更好!

反馈提交失败,请稍后再试!

*必选

请至少选择或填写一项反馈信息

字符长度不能超过200

提交反馈 取消

如您有其它疑问,您也可以通过华为云社区问答频道来与我们联系探讨

跳转到云社区